【ティラノスクリプト 交流掲示板】 2925388


HTML5ゲームエンジン、「ティラノスクリプト」に関する掲示板です

質問を書き込む前に

こんな機能ないかな?と思った時
ティラノスクリプトのタグリファレンス

ティラノWikiも確認
http://tyrano.wiki.fc2.com/

バグ報告や質問、要望などご自由にお使い下さい。


独自フォントについて

1:かに本舗 :

2017/10/17 (Tue) 21:27:19

最新バージョンを使用させて頂いています。
独自フォントがうまく反映されません。ご指南頂ければと思います。

使いたいフォントは「はんなり明朝」です。
othersに収納済。
font.css
--------------------
@font-face {
    font-family: “はんなり明朝”;
    src: url(“../data/others/Hannari.otf”) format(“opentype”);
    font-weight: normal;
    font-style: normal;

config.tjs
--------------------
;userFace = はんなり明朝,sans-serif; // deffont タグの face 属性に相当

fast.ks
--------------------
;文字の色
[font color="snow"]
;サイズとフォント指定
[font size=14 bold=true Hannari.otf]

最後の行に関しては[font size=14 bold=true "はんなり明朝"]にしても反映されません。
どこがおかしいのか、自分では判断ができません。教えていただけると助かります。宜しくお願いします。
2:かに本舗 :

2017/10/17 (Tue) 21:30:32

掲示板への描きこみ方を間違えたかもしれません。ごめんなさい
3: :

2017/10/25 (Wed) 09:38:45

>>1
貼ってくださったfont.cssのコードに全角の引用符と空白がありますね
たぶんこれが原因ではないかなという気がします

①ティラノスクリプトのスタンダードをダウンロード

②data/othersにHannari.otfを置く

③font.cssにこうかく

/*ウェブフォントを使用する場合はここに定義を追加して下さい*/
@font-face {
font-family: "はんなり明朝";
src: url("../data/others/Hannari.otf") format("opentype");
font-weight: normal;
font-style: normal;
}

④first.ksにこうかく

;一番最初に呼び出されるファイル
[deffont face="はんなり明朝"][resetfont]
はんなり明朝サンプル。[s]

⑤プレビュー

これでうまくいきませんか
4:リベラ :

2018/08/20 (Mon) 20:30:06

お世話になります。MacOSでティラノスクリプトを使い開発しております。
普段windowsを使わないのでMac開発環境があるのはありがたく、快適に開発できています。

独自フォントについて、本掲示板1〜3の書き込みのとおりやってみたところ、
どうしても日本語フォントのみ独自フォントが反映されません。
文字変更のスクリプトを書くと、どんなフォントを指定しても無難な明朝体になってしまいます。
しかし、英数フォントは問題なく反映されます。
試しに、同じファイルを丸ごとwindowsに移して起動したところ、日本語フォントも反映されました。
ファイルの置き場所や、タグは間違っていないがMacでは正しく認識されない、ということのようです。

気になっているのが、アプリ化するところの説明を少し読んだところ
「Iphoneアプリの場合日本語のファイルは文字化けするので使えない」という一文。
しかし、例えば「はんなり明朝」(ファイル名はHannnari.otf)などの、フォント名が日本語でないファイルもダメでした。
もう一つ気になったのは、cssファイルを開いたワードパットが不適合で、コード化け?しているかもしれないという点。
(実際、「"」が別の文字に化けてしまうことが過去にありました)
しかし、それなら英数フォントのみ反映されていることの説明がつきません。

私がMacのルールの何かに詳しくないためうまくいっていないだけのような気はしていますが
何かご存知の方、また心当たりがある方がおられましたら聞かせてください。よろしくお願いいたします。
5:リベラ :

2018/08/20 (Mon) 20:47:23

>>4
すみません、上記書き込み自己解決しました!
ティラノライダーやMacを再起動していたらいつのまにか反映されていました。
大変失礼いたしました。
6:リベラ :

2018/08/20 (Mon) 21:13:00

http://bbs8.fc2.com//bbs/img/_745900/745841/full/745841_1534767180.png 連投失礼します、原因がわかりましたので備忘も兼ね書き込みます

何度かコピーやペーストをしていたところ、やはり再度反映されなくなることがあり
よ〜く見てみると、「"」(正しい)と「”」(誤り)が混ざっていました。
何かの拍子で変わってしまっていたようです。

しかし、バックアップデータを見ると、「”」でも英数字が反映されていたので、
本当にこれが原因だったのか、まだ謎な部分もありますが……。

テキストの色が変わるエディタを使っていて気づきました。お騒がせしました。



  • 名前: E-mail(省略可):
  • 画像:

Copyright © 1999- FC2, inc All Rights Reserved.