【ティラノスクリプト 交流掲示板】 855325


HTML5ゲームエンジン、「ティラノスクリプト」に関する掲示板です

質問を書き込む前に

こんな機能ないかな?と思った時
ティラノスクリプトのタグリファレンス

ティラノWikiも確認
http://tyrano.wiki.fc2.com/

バグ報告や質問、要望などご自由にお使い下さい。


質問用スレッド

1:shikemokuMK:

2012/08/31 (Fri) 17:40:08

ティラノスクリプトに関するわからない事がありましたら、お気軽にどうぞ
65:mas_iwa:

2012/11/27 (Tue) 00:15:46

現在、作成したノベルをスマートフォンで配布するため準備を進めています。
そこでandroidアプリについて質問なのですが……

●「TyranoScript」で作成したゲームは動作環境として、androidのどの
バージョンから対応していると、注意書きなどに表記できそうでしょうか?

ゲームをアプリ化する(Andoroid編 その1)
[ http://tyranoscript.blogspot.jp/2012/10/andoroid.html ]に
BuildSDK:Andoroid 2.3.3
Minimum Required SDK:Andoroid 2.3.3
とありますので制作者様は、2.3.3から対応とお考えでしょうか?

もう一つ質問があります。
上記URLには、新規Androidアプリケーション作成時の項目に
「BuildSDK」「Minimum Required SDK」というふたつが提示されています。

しかし、Eclipse 4.2 で、この項目が以下のように変わっていました。
[Minimum Required SDK : Android2.2(初期表示)]
[Target SDK : Android 4.1(初期表示)]
[Compile SDK : Android 4.2(初期表示)]
[Theme : Holo Light with Dark Action Bar(初期表示)]

●この4項目は、そのまま変更なしで問題ないでしょうか。
TyranoScriptに好都合なので、こうした方がいいというような
指摘はおありでしょうか?

ちなみに私のスマートフォンはAndoroid2.2なので、
[Minimum Required SDK]を2.3.3上げるとインストールに失敗します。

そのため、対応を初期表示の2.2にして、インストールしてテストしました。
私のis04 REGZAでは、全体的に挙動がゆっくり、音楽(BGM,効果音とも)が
上手く鳴らない(ロード機能を使うとまれに鳴ったりする)以外は正常に動いています。

なお仮想ドライブ(AVD)の2.3.3では音楽は流れています。
端末自体のスペックの低さとバージョンの低さ、個人的にはどちらも問題だとは
思うのですが、制作者様側ではどのようなご意見をお持ちか、うかがわせてください。

以上、失礼いたします。
mas_iwa

このトピックはレス満タンなので返信できません。


Copyright © 1999- FC2, inc All Rights Reserved.