【ティラノスクリプト 交流掲示板】 821074


HTML5ゲームエンジン、「ティラノスクリプト」に関する掲示板です

質問を書き込む前に

こんな機能ないかな?と思った時
ティラノスクリプトのタグリファレンス

ティラノWikiも確認
http://tyrano.wiki.fc2.com/

バグ報告や質問、要望などご自由にお使い下さい。


質問用スレッド part2

1:シケモクMK :

2014/12/07 (Sun) 08:50:51

ティラノスクリプトに関するわからない事がありましたら、お気軽にどうぞ

質問する時は、前スレで解決していないか、確認していただけると幸いです。

前スレ 質問用スレッドpart1
http://tyrano.bbs.fc2.com/?act=reply&tid=6151309

982:うどん :

2017/01/27 (Fri) 04:31:43

はじめまして、うどんと申します。
私のようなスクリプトのスの字も分からないような若輩でも扱える素晴らしいツールを作って下さったシケモクMK様、
そしてそれを使いこなしている皆様。
質問掲示板やWikiなども拝読し、いつも大変お世話になっております。

色々と試行錯誤してみたものの
どうしても自分では原因究明をする事が出来なかったのでお力をお貸し頂ければと思い、こちらで質問させて頂きます。
また、同じ質問をなさっているかたがいないか過去ログにもきちんと目を通したつもりですが
見落としをしていたら大変申し訳ありません。

現在、WindowsPC用のゲームを作成しており、
タイトル画面の背景にて[bgmovie]タグを使い短い動画をループ再生しております。

エンディングなどに到達した時にまたタイトル画面へジャンプしてくるように指定してあるのですが、
途中でセーブし、ロードしたデータでエンディングまで到達しタイトルへ戻ってくると
[bgmovie]の所でエラーになり止まってしまいます。
(ゲームスタートからそのままエンディングに到達し、ジャンプする時はエラーは出ません)

試しに[bgmovie]のタグをコメントアウトした所、そのまま(動画の部分以外は)通常通り表示されました。
ティラノスクリプト最新版を新たにDLして来た状態でタイトルに動画を入れ
タイトルにジャンプするようにして試しても、ロードすると同じようにエラーが出て停止したので私のタグの書き方が悪いのではと思っております。

ロードということで、make.ksに何かを記述するのかと思い調べてみたのですが自分の力では解決する事が出来ず…。
(タイトル画面の動画だけでなく、ロードして話を進めた先にある動画も[bgmovie]の所でエラーになります。[movie]の場合は問題なく表示できるのですが…)
ロード→タイトルへ戻るでタイトルへ戻った時は[bgmovie]が再生されるので、
(ゲーム中でも停止してしまうため根本的な解決にはなってないものの)
とりあえず一番最初に戻れば良いのかと思いfirst.ksにジャンプするようにしてみたのですが結果は同じでした。

何か見当はずれな事をしているようでしたら
大変お恥ずかしい限りです。

お忙しい中お時間を割いて頂くのは恐縮ですが、
どのようにすればロードした状態でbgmovieのタグを表示させることが出来るのか
どなたかご教示頂けると幸いです。

長々ととりとめもない文章で申し訳ございませんでした。
どうぞよろしくお願い致します。

  • 名前: E-mail(省略可):
  • 画像:

Copyright © 1999- FC2, inc All Rights Reserved.